【友盟+】开发者社区

友盟自动更新常见问题索引(开发者必读)

push更新 发表于 2016-10-28 22:38:11 |

push更新
push更新 发表于 2014-10-27 17:08:26 | 显示全部楼层 |阅读模式
为避免重复回答,请大家先查看这篇文档整理的问题,我们会定期维护这个帖子!

找不到的问题请发贴,为了方便查找,一个帖子只解决一个问题

送人玫瑰,手留余香

从一个人那里得到帮助,请帮大家解答几个力所能及的问题

1.gif





小白集成:小白集成友盟自动更新Android2.4.2(图文并茂)
IOS:

友盟自动更新IOS如何实现更新


Android:

使用消息推送来做自动更新
自动更新的下载和测试:

自动更新 apk是在哪里上传的

正式上线的APP,如何进行新版本测试
上传的apk有下载链接地址吗
不同的包名用了同一个key会有冲突么
自动更新的APK下载文件在什么位置
放在自有服务器的app可以使用友盟的自动更新吗

自动更新网络环境问题:

手机连接到WiFi网络, 更新提示"非WiFi"环境
自动更新为什么在3G情况下没有提示更新

增量更新问题:

如何测试增量更新
友盟增量更新的原理是什么
如何在代码中决定用增量更新还是全量更新
测试使用出现不了增量更新,一直是全量更新
使用增量更新时,只有arm的so文件,怎样支持x86和mips?

各种出错情况:


自动更新混淆后无法使用怎么办
“自动更新”报错,导致应用崩溃
自动更新下载失败,提示为网络错误
andorid手机自动更新不断下载更新包
APK 上传失败提示 no version Name和version code
应用程序未安装 已安装了存在签名冲突的同名数据包
android客户端 使用增量更新后 ,之前的程序bug仍未修复
测试的时候,第一次增量失败,使用全量之后,再增量成功

其他自动更新问题:

在应用内如何实现多渠道更新
自定义弹窗里面的数据
android自定义弹窗方法
按照间隔提示更新
如何暂停自动更新
如何能够实现强制更新
手动更新之后显示当前最新版本
用户选择忽略更新之后,要怎样才能再检测到更新
自动更新是否会增加渠道的下载量,与渠道的关系如何












上一篇:应用程序未安装 已安装了存在签名冲突的同名数据包
下一篇:静默下载,不显示通知栏的进度条





push更新
push更新 发表于 2015-5-29 17:11:19 | 显示全部楼层
超时检查网络环境,然后有其他问题的,可以添加友盟自动更新官方群:415849781。

SNSports
SNSports 发表于 2015-6-26 09:34:59 | 显示全部楼层
请问友盟有上传APK的API吗?我想跟Jenkins配合做自动化集成,可以方便地发布新版本。

爱家一购
爱家一购 发表于 2015-7-17 11:18:22 | 显示全部楼层
你好,希望自动更新的sdk,提供一个主动检查更新的功能,因为有时候在设置里面有一个检查更新的功能,用户点击之后服务得知更新的状态


蜗牛Ooooo
蜗牛Ooooo 发表于 2015-7-25 22:35:32 | 显示全部楼层
目前我程序已经发布出去,我用的是自己写的下载程序,一直都可以更新 没发现增量的问题 一直到第二个版本的时候 发现 下载下来是个patch文件 更新不了了! 能在服务端启用一个按钮关闭增量更新吗?



wu11
wu11 发表于 2015-10-4 19:35:04 | 显示全部楼层
api 23混淆编译通不过,因为api23移除了Notification.setLatestEventInfo()方法。这个要怎么办


其军
其军 发表于 2015-10-19 02:02:30 | 显示全部楼层
wu11 发表于 2015-10-4 19:35
api 23混淆编译通不过,因为api23移除了Notification.setLatestEventInfo()方法。这个要怎么办 ...

你怎么解决的


imikeapp
imikeapp 发表于 2015-10-31 10:49:04 | 显示全部楼层
请问下,我在android studio里面不在manifest文件里设置channel的话,而是在代码里面通过AnalyticsConfig.setChannel(String channel)设置渠道,为啥无法检测到新版本呢?通过测试必须在manifest中设置一个channel才能检测到版本,能帮忙看看是什么问题吗?


xzbwssd
xzbwssd 发表于 2015-11-13 11:21:53 | 显示全部楼层
我用Eclipse直接运行的程序就可以正常更新,打包以后的就提示连接超时。什么情况,可以自己设超时时间么,怎么设置


bicky
bicky 发表于 2015-11-19 10:46:12 | 显示全部楼层
iOS集成最新的自动更新SDK UMCheckUpdate 时报警告,
[Objective-C] 纯文本查看 复制代码
ld: warning: object file (/Users/bicky/Desktop/OEMInAll/Vendor/Umeng/UMCheckUpdate/libUMCheckUpdate.a(CheckUpdateUtil.o)) was built for newer iOS version (9.0) than being linked (7.0)
ld: warning: object file (/Users/bicky/Desktop/OEMInAll/Vendor/Umeng/UMCheckUpdate/libUMCheckUpdate.a(UMCheckUpdate.o)) was built for newer iOS version (9.0) than being linked (7.0)




indexzero
indexzero 发表于 2015-12-3 11:24:03 | 显示全部楼层
wu11 发表于 2015-10-4 19:35
api 23混淆编译通不过,因为api23移除了Notification.setLatestEventInfo()方法。这个要怎么办 ...

同问, 混淆打包蛋疼嘞

indexzero
indexzero 发表于 2015-12-3 11:25:59 | 显示全部楼层
api 23混淆编译通不过,因为api23移除了Notification.setLatestEventInfo()方法。 我也是遇到了,因为要使用新特性 ,不能调低SDK ,官方还有处理办法吗  目前继承的是 umeng-analytics-v5.5.3  & umeng-update-v2.6.0.1




qunzu
qunzu 发表于 2016-10-28 22:38:11 | 显示全部楼层
想问下, 我自己反编译并修改了友盟自动库, 然后自己服务端实现一套和友盟接口一样的数据, 这样侵权不?
您需要登录后才可以发帖 登录 | 立即注册

本版积分规则

发表主题

关注我们

新浪微博
微信

欢迎关注友盟官方微博微信!

在线客服
返回顶部 返回列表