【友盟+】开发者社区

应用程序未安装 已安装了存在签名冲突的同名数据包

banker 发表于 2016-4-26 15:22:24 |

banker
banker 发表于 2014-10-27 15:11:43 | 显示全部楼层 |阅读模式
新版本下载下来后提示:应用程序未安装 已安装了存在签名冲突的同名数据包
这是哪里的问题?要怎么解决?





上一篇:自动更新判断更新状态?
下一篇:友盟自动更新常见问题索引(开发者必读)


push更新
push更新 发表于 2014-10-27 16:01:52 | 显示全部楼层
您好,考虑是您自己打包的时候,签名不一样导致的,只能通过删除错误版本去解决。


push更新
push更新 发表于 2014-11-12 20:15:01 | 显示全部楼层
您好,只能通过我们在后台进行版本删除,开发者不能自己操作,您如果有需求可以私聊我告知版本和appkey信息。

WenJX
WenJX 发表于 2015-2-2 15:58:11 | 显示全部楼层
请问我在友盟上进行的自动更新APP 但是下下来的时候为什么显示未能安装程序呢?急

战BUG佛
战BUG佛 发表于 2015-4-7 16:13:52 | 显示全部楼层
请问我在友盟上进行的自动更新APP 但是下下来的时候为什么显示未能安装程序呢?急



push更新
push更新 发表于 2015-6-18 14:46:45 | 显示全部楼层
您好,考虑是您自己打包的时候,签名不一样导致的,只能通过删除错误版本去解决。只能通过我们在后台进行版本删除,开发者不能自己操作,您如果有需求可以私聊我告知版本和appkey信息。


shifu
shifu 发表于 2015-8-11 20:54:07 | 显示全部楼层
我也是遇见这种情况,但目前解决了。。主要可能是你在开发过程中,手机存在的版本是没有签名过(默认使用提供系统的签名)。
1你要安装你自己签名的apk;
2再次签名更高version的apk上传到友盟
这样就可以了

dfgsdf
dfgsdf 发表于 2015-10-14 17:06:12 | 显示全部楼层
push更新 发表于 2014-11-12 20:15
您好,只能通过我们在后台进行版本删除,开发者不能自己操作,您如果有需求可以私聊我告知版本和appkey信息 ...

您好,我这也出现这样的问题,请问如何联系您,谢谢,急求

京华盟友
京华盟友 发表于 2016-3-28 10:12:03 | 显示全部楼层
dfgsdf 发表于 2015-10-14 17:06
您好,我这也出现这样的问题,请问如何联系您,谢谢,急求

您好,怎么联系您?我也出现了同样的问题

dfdsfs
dfdsfs 发表于 2016-4-26 15:19:33 | 显示全部楼层
WenJX 发表于 2015-2-2 15:58
请问我在友盟上进行的自动更新APP 但是下下来的时候为什么显示未能安装程序呢?急 ...

请问你解决了吗 我是在6.0手机上出现你的情况 其他手机不会

您需要登录后才可以发帖 登录 | 立即注册

本版积分规则

发表主题

精彩推荐

【报错必看】微信您的应用签名不正确,请去微信后台确认
微信如果提示这个错误,请查看debug日志: 箭头所指的为你当前应用的签名及包名,然后打开你的微信后台
无法检测设备有效性
无法检测设备有效性
自定义事件有消息数量,却看不到详情
集成都是OK的,能看到自定义事件的消息数量。却看不到详细的详情。 总是显示数据无法加载,稍后重试。

关注我们

新浪微博
微信

欢迎关注友盟官方微博微信!

在线客服
返回顶部 返回列表