【友盟+】开发者社区

Pod升级报错library not found for xxx

半夏 发表于 2017-2-9 16:30:35 | |阅读模式

半夏
半夏 发表于 2017-2-9 16:30:35 | 显示全部楼层 |阅读模式
本帖最后由 半夏 于 2017-7-11 10:26 编辑

从4.x或5.x版本升级U-Share 6.0报错library not found for xxx

报错类似这种:
pod.png


由于老版本通过cocoapods集成下载接入全量的平台,包括APOpenSDK、facebook、twitter等。在新版U-Share通过cocoapods集成可以灵活的单选平台,没有加入Podfile配置文件的不会下载。 可以到项目 - Build Setting - Other linker flag 查看是否有多余的库依赖,确认后删除即可。
粘贴图片.png



上一篇:Pod集成找不到UMengUShare
下一篇:Cocoapods library not found for -lPods

您需要登录后才可以发帖 登录 | 立即注册

本版积分规则

发表主题

精彩推荐

Xcode9 beat2 编译出错
今天安装了Xcode9 beat2 版本,感觉还不错,就兴冲冲的去编译公司项目,然后发现悲了个催了 ,,编译不通
6.4.5版本sdk,新浪分享内存泄漏
新浪分享的时候,sdk内部持有了Activity造成了内存泄漏
iOS 分享word文件到微信
1. 有个需求是下载网络上的word文件,并分享到微信好友,结果分享出来的不正确。 有指教的吗。。。。

关注我们

新浪微博
微信

欢迎关注友盟官方微博微信!

在线客服
返回顶部 返回列表