【友盟+】开发者社区

如何能够实现强制更新?

发表于 2014-8-26 14:16:04 | |阅读模式

push更新
push更新 发表于 2014-8-26 14:16:04 | 显示全部楼层 |阅读模式
目前SDK里面并没有直接设计强制更新的功能,现在需要在线参数sdk可以实现在线参数可以设置一个数值,比如10,然后客户端读取这个值,和apk自身的version code比较一下,如果小于这个值,就执行强制更新,监听对话框点击事件,如果没有选择更新就提示用户要更新才能使用,大概是这么个思路。










上一篇:自动更新混淆后无法使用怎么办?
下一篇:友盟自动更新IOS如何实现更新

您需要登录后才可以发帖 登录 | 立即注册

本版积分规则

发表主题

精彩推荐

U-App即将升级,一站式运营你的“超级用户”
底部大福利,可优先体验内测账号哦~ 超级用户火了,因为互联网公司都感受到存量竞争的压力,App的运营核心
关于事件计算口径变更说明(2018.5.15)
影响范围:AppTrack产品全局数据1)计算基准的变更事件计算的周期基准变更:计算基于点击发生日期后续15天
友盟+大揭秘:阿里“亲橙里”的数据黑科技
4月28日,阿里首个智慧商业亲橙里开业。汇集盒马鲜生、天猫国际、天猫精灵、阿里小厨等众多业态,亲橙里通

关注我们

新浪微博
微信

欢迎关注友盟官方微博微信!

返回列表